Anonymní profil wieszak – Programujte.com
 x   TIP: Přetáhni ikonu na hlavní panel pro připnutí webu

Anonymní profil wieszak – Programujte.comAnonymní profil wieszak – Programujte.com

 

Příspěvky odeslané z IP adresy 78.157.167.–

wieszak
Mikrokontroléry › PICkit2 - problém s naprogra…
31. 7. 2013   #179744

#10 KIIV
Dráty jsou teď sice o něco delší než předtím, ale tohle asi nevadí, protože programování a ten zbytek už normálně funguje :) A zapojení bylo předtím i teď úplně stejně, takže to problém nedělalo. Bylo to fakt nejspíš v tom, že v programátoru v konektoru ICSP to moc dobře předtím nedrželo :) Ale i tak ještě jednou díky za pomoct :D

wieszak
Mikrokontroléry › PICkit2 - problém s naprogra…
31. 7. 2013   #179739

Problém jsem nakonec dneska vyřešil. Bylo to pouze v "drátech" (jestli to tak můžu nazvat), které byly připojené mezi ICSP a MCU. Včera jsem měl připojené tenčí drátky, které moc dobře nedržely v konektoru. Tohle by vysvětlovalo, proč vyskakovala hláška "No device detected". Drátky jsem dneska vyměnil za hrubší, které v konektoru drží pevněji a PICkit2 mi dokonce sám detekoval připojený MCU a už funguje i naprogramování, mazání, verifikace,... :) Takže se zdá, že je problém vyřešen. Každopádně díky za pomoc :)

wieszak
Mikrokontroléry › PICkit2 - problém s naprogra…
30. 7. 2013   #179727

Tak jsem zaktualizoval PICkit2 Programmer na verzi 2.61.00 a OS Firmware na verzi 2.32.00 a teď mi při pokusu o čtení MCU píše "No device detected" :(

wieszak
Mikrokontroléry › PICkit2 - problém s naprogra…
30. 7. 2013   #179726

#6 KIIV
Code Protect i Data Protect mám vypnuty. Chyba mi vyskakuje při zapisování i při verifikaci. Čtení a mazání funguje normálně. Před chvilkou jsem v PICkitu otevřel "Programmer > PICkit 2 Programmer-To-Go..." a přes něj nahrál do starého PIC16F84A jeden prográmek. Pak jsem PICkit odpojil od USB a sestavil obvod, ve kterým jsem si ověřil, že program v MCU je nahraný. Přes Write se mi ho ale nahrát zase nepovedlo. Zkusím ještě aktualizaci OS programátoru a softwaru na nejnovější.

wieszak
Mikrokontroléry › PICkit2 - problém s naprogra…
30. 7. 2013   #179724

Navíc... když kliknu v TOOLS > Check Communication, tak se mi zobrazí hláška "PICkit2 found and connected. [Parts in this family are not auto-detected.]" Dělá mi to i u PIC16F628 i u PIC16F84A. I přes to, že to vyberu manuálně, importuji HEX pro příslušný MCU a kliknu Write, tak vyskakuje pořád ta chyba. Už jsem i u VDD PICkit2 zaškrtnul volbu "On" a nastavil 5,0V. Přemýšlím, zda nejsou ještě tyhle MCU, po těchto "pokusech", mrtvé.

wieszak
Mikrokontroléry › PICkit2 - problém s naprogra…
30. 7. 2013   #179721

#2 KIIV
Programátor mám teprve ode dneška a v PICkit2 dělám úplně poprvé. Ještě se mi v něm nepovedlo naprogramovat žádný MCU. Kdysi jsem programoval PIC16F84 s programátorem, který jsem si vyrobil doma. Nemám ani žádný vývojový kit. Mám pouze ten PICkit2 a ICSP je připojený k MCU v nepájivém poli bez nějakých rezistorů nebo kondíku.

wieszak
Mikrokontroléry › PICkit2 - problém s naprogra…
30. 7. 2013   #179719

Zdravím. Dneska jsem si koupil PICkit2 a k němu PIC16F628. Nainstaloval jsem si PICkit2 v2.50, do PICkitu stahnul OS. Pak jsem připojil ICSP k MCU podle tohoto "schéma": http://upload.wikimedia.org/wikipedia/commons/thumb/6/6b/Pic_icsp.jpg/600px-Pic_icsp.jpg

Stáhnul jsem si program přímo pro tenhle tenhle PIC a při programování mi vyskočila hláška "Programming failed at Program Memory address 0x000000". Takhle mi to udělalo několikrát za sebou. Můžete mi prosím někdo poradit, co může být špatně? Předem díky za odpovědi

 

 

Hostujeme u Českého hostingu       ISSN 1801-1586       ⇡ Nahoru Webtea.cz logo © 20032017 Programujte.com
Zasadilo a pěstuje Webtea.cz, šéfredaktor Lukáš Churý