× Aktuálně z oboru

Programátoři po celém světě dnes slaví Den programátorů [ clanek/2018091300-programatori-po-celem-svete-dnes-slavi-den-programatoru/ ]
Celá zprávička [ clanek/2018091300-programatori-po-celem-svete-dnes-slavi-den-programatoru/ ]

Vydání Eclipse PDT (PHP) se zpozdí

[ http://programujte.com/profil/4089-zdenek-vecera/ ]Google [ https://plus.google.com/+ZdenekVecera?rel=author ]       [ http://programujte.com/profil/118-zdenek-lehocky/ ]Google [ ?rel=author ]       28. 2. 2007       10 791×

Open-source projekt PDT vychází z vývojové platformy Eclipse [ http://www.eclipse.org ]. Je je dostupný na mnoha operačních systémech díky jazyku Java, kterým byl naprogramován. Eclipse PDT [ http://www.eclipse.org/php ] si klade za cíl přinést komplexní nástroj pro vývoj PHP aplikací, a tím se stává žhavým konkurentem nejen nástrojů Zend Studio [ http://www.zend.com/products/zend_studio ] nebo třeba PHP Designer [ http://www.mpsoftware.dk/products.php ]. Přeci jen, velká výhoda Eclipse PHP spočívá v dostupnosti na mnoha platformách a nulové ceně.

Eclipse PDT se v současné době nachází ve verzi 0.7 RC2 (v rámci stabilních verzí), přičemž konečný stabilní release 0.7 byl naplánován na 28. února 2007. Bohužel došlo k odložení vydání až na březen 2007.

Eclipse PDT byl dlouhou dobu relativně chybový projekt, naštěstí vydáním RC1 již směřuje ke kvalitnímu nástroji. Každý den je vývojáři odváděna velká spousta práce, ostatně, můžete se o tom sami přesvědčit u pravidelně vydávaných tzv. nočních buildů, které jsou nabízeny ke stažení [ http://download.eclipse.org/tools/php/downloads/index.php ].

Pokud chcete začít Eclipse PDT používat, bylo by rozumné sáhnout po starší RC2 verzi, kterou můžete stahovat [ http://download.eclipse.org/tools/php/downloads/index.php?release=S20070130-RC2 ] z oficiálních stránek. Eclipse PDT je dostupné pro platformy Windows, Linux a Mac OS, přičemž kompletní verze balíčku, tzv. PDT All-in-One (již nic jiného nebudete muset stahovat) se pohybuje okolo 95 MB.

Ještě jednou upozorňujeme, že se jedná o nástroj napsaný v jazyce Java, takže je třeba, abyste měli na svém počítači nainstalované prostředí Java Runtime Environment (JRE) [ http://javashoplm.sun.com/ECom/docs/Welcome.jsp?StoreId=22&PartDetailId=jre-1.5.0_11-oth-JPR&SiteId=JSC&TransactionId=noregURL ].


Článek stažen z webu Programujte.com [ http://programujte.com/clanek/2007022701-vydani-eclipse-pdt-php-se-zpozdi/ ].