Instalace Apache - problém – Webové servery (Apache, IIS...), .htaccess – Fórum – Programujte.com
 x   TIP: Přetáhni ikonu na hlavní panel pro připnutí webu
Reklama
Reklama

Instalace Apache - problém – Webové servery (Apache, IIS...), .htaccess – Fórum – Programujte.comInstalace Apache - problém – Webové servery (Apache, IIS...), .htaccess – Fórum – Programujte.com

 

Hledá se programátor! Plat 1 800 € + bonusy (firma Boxmol.com)
Yankee
~ Anonymní uživatel
2 příspěvky
7. 3. 2008   #1
-
0
-

Prosím pomozte. Začínám se serverem Apache a asi dělám nějakou trivialní chybu. Podle článku za 14.1.2007 jsem si nainstaloval server Apache 2.2.8 a chci pokračovat v instalaci php a MySQL. PhP a MySQL zatím nainstalované nemám. Po instalaci Apače jsem dle návodu konfiguroval soubor httpd.conf. Když nyni ale v prohlížeči (Firefox) zadám http://localhost objeví se okénko s nápisem, že je vyžadována autentifikace a chce to po mě jméno a heslo. Nevím jaké přihlašovací údaje zadat nebo jak se toho okna zbavit. Omlouvám se všem znalým za svůj stupidní dotaz - prosím pomozte. Díky

Nahlásit jako SPAM
IP: 88.103.56.–
Reklama
Reklama
yankee
~ Anonymní uživatel
2 příspěvky
7. 3. 2008   #2
-
0
-

To Yankee :
tak jsem již objevil příčinu svých potíží, teď ještě najít optimální řešení:

Při instalaci serveru Apache se instalátor ptá, zda chceme server instalovat -
- pro všechny uživatele, na portu 80 - jako službu - toto je doporučená instalace
- pro aktuálního uživatele na portu 8080 - při ručním spouštění.

Instaloval jsem tak jak je doporučeno. Jenže při spuštění Apache to hodilo chybu, že IP nebo port je již použit. Tak jsem jednoduše v konfiguračním souboru změnil v položce Listen hodnotu 80 na 8080. Pak se server spustí, ale s požadavkem na autentifikaci. Dám-li při autentifikaci 2x storno, objeví se stránka s textem a je tam info o chybě 401,2.

Nyní jsem zjistil, že mi na notebooku běží jako služba zároveň server IIS a právě na portu 80. Zastavil jsem tuto službu, v konfiguračním souboru Apache přepsal položku Listen na 80 a už to funguje. No a teď jaké řešení zvolit? Asi budu nucen Apache přeinstalovat pro ruční spouštění - pak budu moci nechat IIS běžet. Pokud někdo připojíte komentář, díky.

Nahlásit jako SPAM
IP: 88.103.56.–
Zjistit počet nových příspěvků

Přidej příspěvek

Toto téma je starší jak čtvrt roku – přidej svůj příspěvek jen tehdy, máš-li k tématu opravdu co říct!

Ano, opravdu chci reagovat → zobrazí formulář pro přidání příspěvku

×Vložení zdrojáku

×Vložení obrázku

Vložit URL obrázku Vybrat obrázek na disku
Vlož URL adresu obrázku:
Klikni a vyber obrázek z počítače:

×Vložení videa

Aktuálně jsou podporována videa ze serverů YouTube, Vimeo a Dailymotion.
×
 
Podporujeme Gravatara.
Zadej URL adresu Avatara (40 x 40 px) nebo emailovou adresu pro použití Gravatara.
Email nikam neukládáme, po získání Gravatara je zahozen.
-
Pravidla pro psaní příspěvků, používej diakritiku. ENTER pro nový odstavec, SHIFT + ENTER pro nový řádek.
Sledovat nové příspěvky (pouze pro přihlášené)
Sleduj vlákno a v případě přidání nového příspěvku o tom budeš vědět mezi prvními.
Reaguješ na příspěvek:

Uživatelé prohlížející si toto vlákno

Uživatelé on-line: 0 registrovaných, 2 hosté

 

Hostujeme u Českého hostingu       ISSN 1801-1586       ⇡ Nahoru Webtea.cz logo © 20032016 Programujte.com
Zasadilo a pěstuje Webtea.cz, šéfredaktor Lukáš Churý